【Flutter】Package dependencies

/ 0评 / 0

Flutter依赖配置方案

1、范围限制: 指定一个最小和最大的版本号

dependencies:
  collection: '>=2.3.5 <2.4.0'

2、范围限制使用 caret 语法

dependencies:
  collection: '^0.1.2'

^1.2.3 等同于 '>=1.2.3 <2.0.0'

^0.1.2 等同于 '>=0.1.2 <0.2.0'

依赖未发布的packages

1、路径依赖

dependencies:
  plugin1:
    path: ../plugin1/

路径可以是相对的,也可以是绝对的。例如,要依赖位于应用相邻目录中的插件’plugin1’,请使用以下语法

2.1、Git依赖:如果软件包位于仓库的根目录中,请使用以下语法

dependencies:
  plugin1:
    git:
      url: git://github.com/flutter/plugin1.git

2.1、Git依赖:Pub假定包位于Git存储库的根目录中。如果不是这种情况,您可以使用path参数指定位置

dependencies:
  package1:
    git:
      url: git://github.com/flutter/packages.git
      path: packages/package1

依赖其他三方库源

dependencies:
  transmogrify:
    hosted:
      name: transmogrify
      url: http://some-package-server.com
    version: ^1.0.0

有时候软件包在私有的服务器上不在https://pub.dev/上,则可以使用这种方法

覆盖依赖

name: my_app
dependencies:
  transmogrify: ^1.2.0
dependency_overrides:
  transmogrify: '3.2.1'

tip:不仅仅可以覆盖版本,还可以覆盖到本地依赖

参考网址:

https://dart.dev/tools/pub/dependencies

发表评论

您的电子邮箱地址不会被公开。